Multistrada 950

Please login or register.

News: A big welcome to all new members !


Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Gear Position Indicator problem (+ some test rides)  (Read 675 times)

0 Members and 1 Guest are viewing this topic.

Offline BrownTrousers

  • MTS 950 Pro
  • ***
  • Posts: 121
  • Bike: 2018 MTS 950 RED
  • Town / City: Cambridge
  • Country: gb
Gear Position Indicator problem (+ some test rides)
« on: July 31, 2020, 07:29:17 PM »
So I had a problem with my gear position indicator which might be of interest to people now or in the future if anyone gets similar.....

At first I noted that when in 4th, the indicator would show different random gears. Then later on in the same long ride,  it started showing random numbers when in all the gears. Then a bit later on still, it started occasionally showing "blank" and the neutral night occasionally came on when cruising along in gear. Eventually, as I was almost home, the engine warning light came on.
The bike ran fine during all of this.

I took it back to Ducati (Cambridge) and they pre-ordered a new sensor to be fitted. After two days delay, they finally gave it back to me, all fixed. He said all they did was change the sensor and the delay was clearing the computer fault codes. I got no paperwork but wasn't going to push them on it since they did it all free of charge "under warranty" (even though I'm out of warranty by 2 months: I'm still not sure if this was kindness or incompetence on their part).

Anyway, I'd be interested to hear if anyone comes across similar!? All seems well with the fix so far.
Previous bikes: Tiger 800XR & CRB500R
Bikers make great organ donors - sign up here

Offline BrownTrousers

  • MTS 950 Pro
  • ***
  • Posts: 121
  • Bike: 2018 MTS 950 RED
  • Town / City: Cambridge
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #1 on: July 31, 2020, 07:35:39 PM »
As an aside, I borrowed a "big boy" Multiatrada and then a 1100 Scrambler Sport Pro whilst they had mine...

Big Multi:
I was worried I would want one, but I actually I needn't have worried. The engine was awesome but way beyond what I can use and I found the pegs to be a bit awkward (my feet knocked on exhaust or engine).

Big Scrambler:
I liked the riding position on this particular variant, although it wasn't very "Scrambler-y". I was reminded me how exposed (fast) a naked bike feels. Fun when in the right mood. I do want a naked bike but not as my only bike, so I'd probably stick with a cheaper one (like the scrambler 800) in that case.
Previous bikes: Tiger 800XR & CRB500R
Bikers make great organ donors - sign up here

Offline buzzardbilly

  • MTS 950 Pro
  • ***
  • Posts: 249
  • Town / City: Gloucester
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #2 on: August 01, 2020, 12:30:32 PM »
Was that the Gear Position Indicator Switch that was replaced ? After 10k miles I have just had a similar problem - bike would go into neutral but was still showing 1st . I could let the clutch out so was def neutral but the bike acted in other ways as though it was in gear ie wouldn't let me start unless the clutch was in / side stand up (it also sounded a bit noisier going into 1st or 2nd whilst stationary)

I think a couple of others (Jonny H and TO17NYB) have had this switch replaced and I was wondering if this is a quick job (external switch to the gearbox) or a bit of a strip down job and is it expensive as I am not under warranty

Am going on a tour in a couple of weeks so don't want to risk it being in bits at the dealers

Offline BabyD

  • MTS 950 Master
  • ****
  • Posts: 584
  • Bike: Multi 1260s
  • Town / City: Buckinghamshire
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #3 on: August 01, 2020, 03:02:56 PM »
*Originally Posted by BrownTrousers [+]
I borrowed a "big boy" Multistrada  :305:  :745:
If I had a second brain cell it would be so lonely......

Offline Goldstar

  • MTS 950 Pro
  • ***
  • Posts: 143
  • Bike: MTS 950 & 797+
  • Town / City: Norfolk
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #4 on: August 01, 2020, 06:41:18 PM »
Looks like an external component, item 16



Offline buzzardbilly

  • MTS 950 Pro
  • ***
  • Posts: 249
  • Town / City: Gloucester
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #5 on: August 02, 2020, 09:31:44 AM »
 Thanks Goldstar - yep I checked on that site as well - so potentially it doesn't look too bad
Cheers

Offline Wassers

  • MTS 950 God
  • *****
  • Posts: 1142
  • Bike: MTS & Speed Twin
  • Town / City: Berkshire
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #6 on: August 04, 2020, 01:17:23 PM »
I had the same problem on my previous 950.

It was replaced FOC whilst under guarantee, so it looks like the gear position indicator going faulty is a common issue - but I've not yet seen it occur on a 950s. Perhaps they've now cured the issue.
Sometimes you need a really crooked road to get your head straight

Offline Ian_H

  • MTS 950 Member
  • **
  • Posts: 66
  • Town / City: Amersham
  • Country: gb
Re: Gear Position Indicator problem (+ some test rides)
« Reply #7 on: August 05, 2020, 07:57:29 AM »
*Originally Posted by buzzardbilly [+]
Was that the Gear Position Indicator Switch that was replaced ? After 10k miles I have just had a similar problem - bike would go into neutral but was still showing 1st . I could let the clutch out so was def neutral but the bike acted in other ways as though it was in gear ie wouldn't let me start unless the clutch was in / side stand up (it also sounded a bit noisier going into 1st or 2nd whilst stationary)

I had exactly the same problem. In neutral, bike thought it was in second.
Although for me was made worse as the clutch lever sensor had gone so bike wouldn't even try and start as it thought clutch was out permanently even when I pullded it in.

All sorted fairly quickly.

Offline Desmofonso

  • MTS 950 Member
  • **
  • Posts: 17
  • Country: es
Re: Gear Position Indicator problem (+ some test rides)
« Reply #8 on: August 05, 2020, 05:32:04 PM »
Some other members had the same problem... or similar (see this trhead https://www.multistrada950.com/forum/index.php/topic,825.0.html)

In other forums mechanics and professional people from Ducati talks about the gear lever (feet) must be properly adjust and firmly actioned. If the sensor is ok, but the indication is wrong, maybe the "Tips & Tricks Bulletin SRV-TTB-16-003" can be usefull. Google it, read it, understand it... and try. :164:

Offline GKRider

  • MTS 950 Member
  • **
  • Posts: 12
  • Bike: 18MTS
  • Town / City: BOTANY
  • Country: au
Re: Gear Position Indicator problem (+ some test rides)
« Reply #9 on: September 02, 2020, 12:13:49 AM »

Had mine fail at 20k ks,replaced under warranty, no probs. sounding fairly common.
 Even outside warranty it should be replaced FOC. IMHO.