Multistrada 950

Please login or register.

News: A big welcome to all new members !


Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Petrol icon problem  (Read 1434 times)

0 Members and 1 Guest are viewing this topic.

Offline InaneScribble27

  • MTS 950 Member
  • **
  • Posts: 17
  • Country: gb
Petrol icon problem
« on: December 25, 2017, 10:12:30 PM »
Got caught in a downpour today while riding, full tank of petrol but the fuel light randomly flashes on and off. Anyone else had this issue?

Online neilb

  • MTS 950 Master
  • ****
  • Posts: 631
  • Bike: MTS 950 Red
  • Town / City: Billericay, Essex
  • Country: gb
Re: Petrol icon problem
« Reply #1 on: December 25, 2017, 10:32:47 PM »
Not happened to me but I've not been caught in really heavy rain yet.

Offline Murf46

  • MTS 950 God
  • *****
  • Posts: 1057
  • Town / City: newcastle upon tyne
  • Country: gb
Re: Petrol icon problem
« Reply #2 on: December 26, 2017, 09:24:27 AM »
Never happened to me
Red or dead

Offline aksdman

  • MTS 950 Junior
  • *
  • Posts: 3
  • Town / City: Subic
  • Country: ph
Re: Petrol icon problem
« Reply #3 on: December 27, 2017, 02:50:27 AM »
*Originally Posted by InaneScribble27 [+]
Got caught in a downpour today while riding, full tank of petrol but the fuel light randomly flashes on and off. Anyone else had this issue?

I've experienced this recently in my Multistrada 950 after around 4k kms of riding.  The fuel light flashes on and off while showing empty even if my tank is full. 

Has anyone else experienced this sort of problem?

Offline Murf46

  • MTS 950 God
  • *****
  • Posts: 1057
  • Town / City: newcastle upon tyne
  • Country: gb
Re: Petrol icon problem
« Reply #4 on: December 27, 2017, 08:49:38 AM »
Again never had a problem


However did get an ice warning light yesterday when the temp fell to 3 degrees  :005:
« Last Edit: December 27, 2017, 08:51:49 AM by Murf46 »
Red or dead

Offline InaneScribble27

  • MTS 950 Member
  • **
  • Posts: 17
  • Country: gb
Re: Petrol icon problem
« Reply #5 on: February 17, 2018, 05:12:56 PM »
Dealer has been investigating this issue, after a week they decided it was the wiring loom, they submitted that to Ducati, Ducati asked exactly what part of the loom, they couldnt then find a fault in the loom, the only thing they could find was th exhaust valve was clogged up. So nothing replaced after two weeks in the workshop, get it back tomorrow.

Offline Conman

  • MTS 950 Pro
  • ***
  • Posts: 387
  • Town / City: Stockport
  • Country: gb
Re: Petrol icon problem
« Reply #6 on: February 18, 2018, 10:54:58 AM »
Not a problem I've had (touch wood). Sounds like it's going to be a bugger to find so best of luck  :003: Lets us know what happens.

I've been through some terrible weather for hours across France and Belgium, the bike was fine (touch wood again!).
If I knew what I was doing I would probably stop doing it.

Offline InaneScribble27

  • MTS 950 Member
  • **
  • Posts: 17
  • Country: gb
Re: Petrol icon problem
« Reply #7 on: February 18, 2018, 11:05:34 AM »
Ive also had a problem with warning coming up in sports mode about traction control jumping to highest level and flashing, hoping thats more to do with exhaust valve