Author Topic: Fitted the Givi today  (Read 1726 times)

0 Members and 1 Guest are viewing this topic.

  • Offline m0mrr   gb

    • MTS 950 Member  ‐    40
    • **

    Offline m0mrr

    • MTS 950 Member
    • **
    • Posts: 40
    • Country: gb
    • Bike: MTS 950
    • Town / City: Cambridge
    Fitted the Givi today
    on: May 08, 2018, 04:55:48 pm
    May 08, 2018, 04:55:48 pm
    Today, I put on my Givi V47 to-box to the bike - its really needed for the work commute. I used the Givi universal mounting plate on the existing grab rail for the bike, as extra security I also used a couple of big heavy duty cable ties just in case anything slips. After testing the ride with just the plate, then top box also attached, all seems fine. Has anyone done anything similar using this mounting plate? I'd be interested in any comments.




  • Offline m0mrr   gb

    • MTS 950 Member  ‐    40
    • **
      #1

    Offline m0mrr

    • MTS 950 Member
    • **
    • Posts: 40
    • Country: gb
    • Bike: MTS 950
    • Town / City: Cambridge
    Re: Fitted the Givi today
    Reply #1 on: May 08, 2018, 04:58:40 pm
    May 08, 2018, 04:58:40 pm
    I probably added this to the wrong forum section, apologies from a newbie lol

    Offline Ferret   england

    • MTS 950 Member  ‐    17
    • **
      #2

    Offline Ferret

    • MTS 950 Member
    • **
    • Posts: 17
    • Country: england
    • Town / City: Norfolk
    Re: Fitted the Givi today
    Reply #2 on: May 08, 2018, 06:50:20 pm
    May 08, 2018, 06:50:20 pm
    Looks like it's worked just fine to me .